Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
2019-09-20 13:25 CDT · 2 minutes, 1 second

Updates

Resolved

Service is back up.

September 20, 2019 · 01:27 PM CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

September 20, 2019 · 01:25 PM CDT

← Back