Digital Instructional Resource Issue Confirmed/In Progress

Major incident Digital Instructional Resources ED - HMH Holt McDougal Online - HMH
2021-04-20 12:46 CDT · 4 hours, 35 minutes, 30 seconds

Updates

Resolved

The issue with this resource has been resolved.

April 20, 2021 · 05:22 PM CDT
Issue

The LISD Technology Team has confirmed an issue with this resource and has started working to resolve it.

April 20, 2021 · 12:50 PM CDT

← Back