Self Service (MDM) is experiencing enrollment failures and general slowness

Major incident Self Service (MDM)
05-05-2021 04:25 PM CDT · 3 hours, 10 minutes

Updates

Resolved

The database performance has returned to normal

November 4, 2021 · 10:25 AM CDT
Issue

We’ve identified an issue with the Self Service (MDM) database server. We are working with our vendor’s support team to resolve the issue. Device enrollments may fail during this time.

November 4, 2021 · 10:25 AM CDT

← Back