Service Self Service (MDM) seems to be down

Major incident Self Service (MDM)
10-05-2019 10:45 AM CDT · 6 hours, 34 minutes

Updates

Resolved

Service is back up.

October 5, 2019 · 05:19 PM CDT
Issue

Our monitoring system has found out the service Self Service (MDM) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

October 5, 2019 · 10:45 AM CDT

← Back