Service Technology Help Portal (LiveTime http://support.lisd.net) seems to be down

Major incident Technology Help Portal (http://support.lisd.net)
1 hour, 42 minutes, 11 seconds

Updates

Resolved

Service is back up.

October 5, 2019 · 12:33 CDT
Issue

Our monitoring system has found out the service Technology Help Portal (LiveTime http://support.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

October 5, 2019 · 10:51 CDT