Service Munis seems to be down

Major Incident Munis
13 minutes

Update

Resolved

Service is back up.

Oct 5th, 2019 11:42 CDT
Issue

Our monitoring system has found out the service Munis is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

Oct 5th, 2019 11:29 CDT