Edgenuity Courseware Errors

Major incident Edgenuity
2021-05-27 13:48 CDT · 17 hours, 45 minutes, 15 seconds

Updates

Resolved

All Systems Operational

May 28, 2021 · 07:34 AM CDT
Monitoring

A fix has been implemented and we are monitoring the results. Posted 14 minutes ago. May 27, 2021 - 12:26 MST

May 27, 2021 · 02:42 PM CDT
Investigating

Edgenuity is currently looking into reports of unexpected errors and is currently investigating this issue.

May 27, 2021 · 01:51 PM CDT

← Back