Service Technology Help Portal (LiveTime http://support.lisd.net) seems to be down

Major incident Technology Help Portal (http://support.lisd.net)
2019-10-22 19:56 CDT · 6 minutes, 5 seconds

Updates

Resolved

Service is back up.

October 22, 2019 · 08:02 PM CDT
Issue

Our monitoring system has found out the service Technology Help Portal (LiveTime http://support.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

October 22, 2019 · 07:56 PM CDT

← Back