Google Authentication issues

Major incident Classlink SSO Google
2021-07-13 08:00 CST · 2 days, 6 hours, 22 minutes, 44 seconds

Updates

Resolved

Issue has been resolved with vendor.

July 15, 2021 · 02:22 PM CST
Issue

We have confirmed issues with fresh/new logins to Google services. We are working to resolve the problem.

July 13, 2021 · 08:56 AM CST

← Back