Canvas New Quizzes is Down

Major incident Canvas
2021-08-23 10:04 CST · 2 days, 23 hours, 26 minutes, 25 seconds

Updates

Resolved

Issue was resolved on 8/23 but the incident was not closed

August 26, 2021 · 09:30 AM CST
Issue

Canvas New Quizzes is down - all users (teacher creating or student using) are getting an error indicating the website is under heavy load and to please try again later. The issue has been reported to Canvas and updates will be provided as they become available.

August 23, 2021 · 10:09 AM CST

← Back