General slowness and failure to load in Technology Help Portal (IncidentIQ)

Major incident Technology Help Portal (http://support.lisd.net)
2021-08-25 10:49 CST · 3 hours, 33 minutes, 32 seconds

Updates

Resolved

IIQ support reported that the issues have been resolved.

August 25, 2021 · 02:22 PM CST
Issue

IncidentIQ support has confirmed they are experiencing issues. Updates will be provided as we learn more.

August 25, 2021 · 10:50 AM CST

← Back