Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
1 hour, 29 minutes, 50 seconds

Updates

Resolved

Service is back up.

November 8, 2019 · 11:57 CST
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 8, 2019 · 10:27 CST

← Back