Service LISD Website (http://www.lisd.net) seems to be down

Major incident LISD Website (http://www.lisd.net)
2 days, 18 hours, 11 minutes, 54 seconds

Updates

Resolved

Service is back up.

November 11, 2019 · 10:22 CDT
Issue

Our monitoring system has found out the service LISD Website (http://www.lisd.net) is currently unresponsive, we’ll look into this now and let you know as soon as we know more.

November 8, 2019 · 16:10 CDT