Digital Instructional Resource Issue Confirmed/In Progress

Major incident Digital Instructional Resources Istation
2021-09-07 10:54 CST · 3 hours, 19 minutes, 55 seconds

Updates

Resolved

The login issue seems to have been resolved.

September 7, 2021 · 02:13 PM CST
Issue

The LISD Technology Team has confirmed an issue with this resource and has started working to resolve it.

September 7, 2021 · 10:59 AM CST

← Back