Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Cengage - MindTap
10-18-2021 11:52 AM CDT · 39 minutes

Updates

Resolved

The issue with this resource has been resolved.

November 4, 2021 · 10:25 AM CDT
Investigating

Users have reported an issue with this resource. The LISD Technology Team is investigating.

November 4, 2021 · 10:25 AM CDT

← Back