Digital Instructional Resource Issue Confirmed/In Progres

Major incident Digital Instructional Resources Holt McDougal - HMH HMH - ED
11-03-2021 10:27 AM CDT · 36 minutes

Updates

Resolved

The issue with this resource has been resolved.

November 4, 2021 · 10:26 AM CDT
Issue

Users have reported an issue with this resource. The LISD Technology Team is investigating.

November 4, 2021 · 10:26 AM CDT

← Back