Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Savvas Realize
12-07-2021 09:50 AM CDT · 21 hours, 35 minutes

Updates

Resolved

This resource should be back to normal working conditions.

December 8, 2021 · 07:25 AM CDT
Investigating

Users have reported an issue with this resource. The LISD Technology Team is investigating.

December 7, 2021 · 09:50 AM CDT

← Back