Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources McGraw Hill - ConnectED
12-07-2021 10:23 AM CDT · 21 hours

Updates

Resolved

The resource should be back to normal working conditions.

December 8, 2021 · 07:24 AM CDT
Investigating

Users have reported an issue with this resource. The LISD Technology Team is investigating this issue with the publisher.

December 7, 2021 · 10:25 AM CDT

← Back