Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Mindplay
02-07-2022 12:11 PM CDT · 5 minutes

Updates

Resolved

The error of logging in has been resloved.

February 7, 2022 · 12:16 PM CDT
Investigating

Users are not able to access Mindplay at this time.

February 7, 2022 · 12:12 PM CDT

← Back