Internet connectivity issues
      
Major incident
      
        Infrastructure
        Internet
    
    
      
02-17-2022 10:40 AM CST
      
      · 20 minutes
    
  Updates
          Resolved
        
        
February 17, 2022 · 11:00 AM CST
        
      
      LISD’s internet connection has been switched to our backup ISP. Internet connectivity has been restored.
          Issue
        
        
February 17, 2022 · 10:58 AM CST
        
      
  The network team is investigating internet connectivity issues.
← Back
            
Lewisville ISD Technology Status