Digital Instructional Resource Issue Confirmed/In Progress
      
Minor incident
      
        Digital Instructional Resources
        Istation
    
    
      
02-22-2022 09:35 AM CST
      
      · 3 hours, 14 minutes
    
  Updates
          Resolved
        
        
February 22, 2022 · 12:49 PM CST
        
      
      iStation Status page displays operational for Single Sign On. All users should be fine now.
          Issue
        
        
February 22, 2022 · 09:38 AM CST
        
      
  Users may experience issues signing into iStation through ClassLink. The vendor’s status page currently has intermittent issues with the Single Sign On.
← Back
            
Lewisville ISD Technology Status