Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources CLI Engage
03-01-2022 09:35 AM CDT · 1 hour, 55 minutes

Updates

Resolved

Users can now log into CLI Engage. Refresh the browser if needed.

March 1, 2022 · 11:31 AM CDT
Issue

Users have reported an issue with this resource. The LISD Technology Team is investigating.

March 1, 2022 · 09:38 AM CDT

← Back