Digital Instructional Resource Issue Confirmed/In Progress

Minor incident Digital Instructional Resources Explore Learning - Reflex Math
03-02-2022 09:24 AM CDT · 4 days, 22 hours, 58 minutes

Updates

Resolved

The Intermittent connection issues has been resolved according to the vendor.

March 7, 2022 · 08:22 AM CDT
Issue

Reflex Math is having intermittent connection issues. Have users keep trying and clearing cache.

March 2, 2022 · 09:25 AM CDT

← Back