Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Savvas Realize
03-10-2022 02:15 PM CDT · 1 hour, 39 minutes

Updates

Resolved

Pearson Savvas has resolved this issue.

March 10, 2022 · 03:55 PM CDT
Investigating

Savvas Realize users are experiencing login issues and/or slowness. Our team is actively troubleshooting the issue.

March 10, 2022 · 02:17 PM CDT

← Back