External email delivery delayed

Major incident Office 365 / Staff Email
2022-03-24 15:12 CST · 2 hours, 33 minutes

Updates

Resolved

Email issue has been resolved

March 24, 2022 · 05:45 PM CST
Issue

Email delivery delayed due to heavy load. Network team is working to resolve.

March 24, 2022 · 03:14 PM CST

← Back