Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources STEMScopes
03-28-2022 08:05 AM CDT · 41 minutes

Updates

Resolved

The issue with this resource has been resolved.

March 28, 2022 · 08:46 AM CDT
Issue

Users have reported an issue with this resource. The LISD Technology Team is investigating.

March 28, 2022 · 08:06 AM CDT

← Back