Unable to Open Some Google Docs

Major incident Learning Hub
2020-01-27 12:32 CDT · 24 minutes, 41 seconds

Updates

Resolved

It appears this issue is resolved.

January 27, 2020 · 12:56 PM CDT
Issue

Ongoing service issue Affected products: Presentations, Spreadsheets, Docs List / Drive, Documents 12:28 PM Description: Some users are having issues opening files in Docs and Drive. Workaround: There’s no workaround available at this time, but we’ll let you know if we learn of one. You’re already subscribed. Check your email for a support case.

January 27, 2020 · 12:35 PM CDT

← Back