Self Service (MDM) is offline

Major incident Self Service (MDM)
04-18-2022 04:00 AM CDT · 23 hours

Updates

Monitoring

Service has been restored. We’ll continue to monitor performance.

April 18, 2022 · 10:13 AM CDT
Issue

Self Service (MDM) is offline. Investigating cause.

April 18, 2022 · 07:53 AM CDT

← Back