Canvas Docview errors

Major incident Canvas
2022-05-13 10:22 CST · 2 hours, 31 minutes

Updates

Resolved

Canvas has resolved the issue.

May 13, 2022 · 12:53 PM CST
Investigating

Canvas users might be receiving errors and long load times when previewing submissions in SpeedGrader.

We are continuing to investigate this issue.

May 13, 2022 · 10:26 AM CST

← Back