Docviewer Errors in Canvas Speedgrader

Major incident Canvas
05-16-2022 08:23 AM CDT · 4 hours, 15 minutes

Updates

Resolved

Canvas has reported that the issue with DocViewer in Canvas Speedgrader has been resolved. They are continuing to monitor and improve the functionality.

May 16, 2022 · 12:39 PM CDT
Investigating

Canvas users might be receiving errors and long load times when previewing submissions in SpeedGrader. Canvas is working to identify the cause and implement a fix.

May 16, 2022 · 08:25 AM CDT

← Back