Technology Help Desk and COVID Call Center phones are offline.

Major incident Infrastructure VoIP Phone System
05-16-2022 01:59 PM CDT · 24 minutes

Updates

Resolved

The issue has been resolved.

May 16, 2022 · 02:24 PM CDT
Issue

The Technology Help Desk and COVID Call Center phones are currently offline. The infrastructure and network team are investigating.

May 16, 2022 · 02:01 PM CDT

← Back