Users are reporting 502 Bad Gateway/slowness within Eduphoria.
      
Major incident
      
        Eduphoria
    
    
      
05-17-2022 10:19 AM CDT
      
      · 4 hours, 59 minutes
    
  Updates
          Resolved
        
        
May 17, 2022 · 03:19 PM CDT
        
      
      Users are reporting 502 Bad Gateway/slowness within Eduphoria. Issue Resolved.
          Investigating
        
        
May 17, 2022 · 10:21 AM CDT
        
      
  9:40am: Users are reporting 502 Bad Gateway/slowness within Eduphoria. Currently under investigation.
← Back
 Lewisville ISD Technology Status
            
Lewisville ISD Technology Status