JAMF Self Service Outage

Major incident Self Service (MDM)
05-18-2022 08:09 AM CDT · 1 hour, 53 minutes

Updates

Resolved

Service has been restored. We’ll continue to monitor.

May 18, 2022 · 10:02 AM CDT
Investigating

JAMF Self Service is experiencing a service interruption. Currently under investigation.

May 18, 2022 · 08:11 AM CDT

← Back