Google.com and associated sites are not loading
      
Major incident
      
        Infrastructure
        Internet
    
    
      
02-11-2020 09:50 AM CST
      
      · 10 minutes
    
  Updates
          Investigating
        
        
November  4, 2021 · 10:24 AM CDT
        
      
      Issue is resolved. Google.com and associated sites are now loading.
          Issue
        
        
November  4, 2021 · 10:24 AM CDT
        
      
  Google.com and associated sites are not resolving DNS lookups. The network team is investigating.
← Back
 Lewisville ISD Technology Status
            
Lewisville ISD Technology Status