Unable to Login to Canvas, Skyward, some other tools

Major incident Canvas Learning Hub Skyward
05-31-2022 07:42 AM CDT · 1 hour, 45 minutes, 1 second

Updates

Resolved

Skyward and Canvas issues have been resolved and is now operational.

May 31, 2022 · 09:27 AM CDT
Issue

There is currently an issue signing into Canvas And an issue signing into Skyward. The TIS department is working to get the issues resolved.

May 31, 2022 · 07:43 AM CDT

← Back