Eduphoria Workshop Links Not Working

Major incident Eduphoria
07-20-2022 09:19 AM CDT · 19 minutes

Updates

Resolved

Eduphoria Workshop Strive links are now working.

July 20, 2022 · 09:38 AM CDT
Issue

Known Issue: Eduphoria Workshop links are not working to register people for professional learning course. This is an Eduphoria system wide issue and the development team is working to resolve.

July 20, 2022 · 09:20 AM CDT

← Back