RevTrak Timing Out

Major incident RevTrak
2022-08-08 17:13 CDT · 1 hour, 40 minutes

Updates

Resolved

The vendor reports this issue has been resolved.

August 8, 2022 · 06:54 PM CDT
Investigating

Users are reporting RevTrak timing out. Vendor reports this is a known issue and high priority.

August 8, 2022 · 05:16 PM CDT

← Back