Digital Instructional Resource Issue Reported

Major incident Digital Instructional Resources Mindplay
08-22-2022 10:41 AM CDT · 2 days, 1 minute

Updates

Resolved

The issue from 8/23 had been resolved.

August 24, 2022 · 10:43 AM CDT
Update

Mindplay has confirmed they are having issue with the ClassLink connections. They are working on resolving the issue.

August 22, 2022 · 12:26 PM CDT
Investigating

Users have reported an issue with this resource. The LISD Technology Team is investigating.

August 22, 2022 · 10:42 AM CDT

← Back