Digital Instructional Resource Issue Confirmed

Major incident Digital Instructional Resources Cengage - MindTap
08-30-2022 12:24 PM CDT · 21 hours, 55 minutes

Updates

Resolved

The issue with this resource has been resolved.

August 31, 2022 · 10:19 AM CDT
Issue

The LISD Technology Team has confirmed an issue with this resource and the vendor has started working to resolve it.

August 30, 2022 · 12:26 PM CDT

← Back