Digital Instructional Resource Issue Confirmed/In Progress

Minor incident Digital Instructional Resources McGraw Hill - ConnectED
09-09-2022 01:09 PM CDT · 2 hours, 20 minutes

Updates

Resolved

The issue with this resource has been resolved.

September 9, 2022 · 03:29 PM CDT
Issue

The LISD Technology Team has confirmed an issue with this resource. This impacts StudySync and other McGraw Hill services. The vendor is working to resolve it.

September 9, 2022 · 01:12 PM CDT

← Back