Digital Instructional Resource Issue Confirmed/In Progress

Major incident Digital Instructional Resources Seesaw

Updates

Update

We have disabled this application in the Learning Hub. Please do not try to access this application via LHUB, mobile application, or website until further notice.

September 14, 2022 · 11:21 AM CDT
Monitoring

At this time SeeSaw has disabled their messaging system due to an incident that occured this morning. If you get an error message attempting to access the messaging with in SeeSaw that is why.

September 14, 2022 · 10:39 AM CDT

← Back